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Contact Details

Issue : 10-11
Printed in Australia

Support Options

E-mail Technical Support
When e-mailing questions to our support staff, make sure you tell us the exact model number (and serial number if possible) of the TRIO 
Datacom equipment you are working with. Include as much detail as possible about the situation, and any tests that you have done which may 
help us to better understand the issue. If possible, please include your telephone contact information should we wish to further clarify any issues.

Hot Standby Base/Repeater Controller (HSC)
The E Series range of Hot Standby Repeater controllers and base 
stations implement a specific set of features and controls that can be 
accessed via TView+ diagnostics.

When this option is selected (via Tools -> Hot Standby Base/Repeater 
Controller)

Select the Hot Standby Controller you wish to access using the drop 
down selection box.

Update Now
Pressing this button will immediately initiate a status poll sequence and 
on successful receipt of a status poll the display will update.

Poll State Toggle Button
•	 Switches automatic status polling ON or OFF.  The poll rate is set 

via the Setup -> Poll Settings menu item. 

•	 The poll rate is dependent on the number of HSC windows that 
are actively polling.

Base Select
This indicates the online status of each unit.

LED colour	 Switch Select State

Off		  Channel not selected (Offline)

Green		  Online (Automatic). Automatic changeovers 		
		  will be actioned by the HSC in response to alarm  	
 	                conditions.

Green Blinking	 Change Over Pending. Waiting for one minute 		
		  time-out period before switching to offline base.

Red		  Selected by TView (Remotely).			 
		  Auto changeovers will not occur.

Amber		  Selected by Switch on HSC (On Site).  Auto 		
		  changeovers will not occur.

Providing either of the bases is not forced online by the switch, the 
user can force either of the bases online remotely by pressing Base 
Select button 1 or 2.  The user can revert back to Automatic mode 
by clicking on the Base Select Auto button.

If the user attempts to switch bases within one minute of a base 
changeover event, the change pending indication will appear (i.e. 
Online Unit LED Blinking Green).  The user should then wait until the 
change over event occurs.

Change Over Events
This is a counter which indicates the number of automatic change 
over events initiated by the HSC due to alarm conditions.

Alarm Status
The current alarm status (since the last alarm status poll) for the 
attached Base units is displayed below.

LED colour	 Error Status

Off		  Unknown. The test hasn’t been performed.

Green	 	 No Alarm. Tests passed.

Red		  Active Alarm. Test failed 

Amber		  Recovered Alarm. Test failed previously but has 	
		  since recovered.
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Quick Start Guide
TView+ Diagnostics
Introduction
Welcome to the Quick Start Guide for the TView+ Diagnostics 
software. This guide provides step-by-step instructions, with 
simple explanations to get you up-and-running. For more detailed 
information, please refer to the TView+ Diagnostics User Manual.

TView+ Diagnostics is for use in conjunction with the D, E M,K & J 
Series Data Radio Modems. The diagnostic facilities allow retrieval of 
critical radio parameters from each radio modem.  

Overview
The TView+ Diagnostics software is a Windows© based program, that 
can be run on a standard desktop or lap top PC.

The TView+ Diagnostics software can be installed as part of the 
TView+ software suite (which includes the E,M&K series programmers) 
or from the stand alone package (zip file) which can be downloaded 
from the support section of the Trio Datacom website.

Installation (TView+ Suite)
Note: If a previous version of the TVIEW+ Management Suite has been 
installed on your PC, you must uninstall it via Control Panel “Add/
Remove Programs”.

•	 Close down all other programs currently running.

•	 Place the CD-ROM in the drive on the PC.

•	 Using Windows Explorer locate the files on the CD-ROM.

•	 In Windows Explorer double click on the file called 
TView+ManagementSuite_Rxxx_Installer.exe 

•	 After the installer starts follow the directions.

Note : For stand alone installation details consult the TView 
Diagnostics User Manual.

TView+ Management Suite 
When started the TView+ management suite will be presented 
(as shown below). TView+ Diagnostics is started by clicking on 
the Diagnostics button.

Introduction (Polled Diagnostics)
This diagnostics process is based on a series of polls being 
transmitted to the remote radio modem with each having its 
own unique assigned address (based on the serial number, 
which is factory preset).

When a diagnostic poll is received by a radio modem it checks 
to see if the poll is addressed to itself and, if so, it responds 
with its diagnostic data (addressed to the TView + diagnostics 
software controller address). 

Introduction (Automatic Diagnostics) E, M & K Series Only
Automatic diagnostics is a feature of the E,M & K Series radio 
modem products. It allows the monitoring of radios in a network 
without the need to generate a poll.

The data returned in automatic diagnostics is fixed  and includes 
5 standard radio parameters. 

Automatic diagnostics is useful in situations where polled 
diagnostics could interfere with user data transfer and cause 
collisions. For more details consult Technical Note TN-67 or 
the E,M & K Series user manuals (all these documents can be 
downloaded from the Support section of our website).

Step 1 - Create/Open a Database
To utilise the diagnostics facilities, a database must be created 
which includes the individual serial numbers, alarm thresholds 
and various other parameters of each radio modem (this applies 
to both polled and automatic diagnostics). 

Note: Some options are specific to various models only.

Create a a database using the menu option File -> New or open 
an existing database using File->Open.

Warning: Do not allow your database file to exceed 60MB, this can 
cause undesireable loss of data when trying to reload the database. 
As a rule of thumb, if you are polling every 5 seconds the database will 
grow approx 20MB per month. Use “archive database between dates’ to 
archive your old database and start a new one.

Step 2 - Add radio to Database
Add any radios you wish to monitor with TView+ diagnostics 
software to the database using the File -> Add/Edit/Delete 
option. To add a new radio click on Add New button. 

Enter the appropriate : Unit Name , Location & Unit Serial Number

   Select the appropriate :

	 • radio Model and Type 
• Communications Port mode (serial or eDiags)

Adjust the alarm limits to suit the individual settings for each radio. All 
other default settings should be suitable for most applications. For a 
detailed explanation of configuration items please refer to the TView+ 
Diagnostics User Manual.

Note : For Hot Standby Systems, both Base Stations that are used as part of 
the Hot Standby must be “paired” together. A drop down box will be displayed 
for Hot Standby Base pairing when more than one Base Station is entered into 
the database. Only the two EB Base Stations that go together to make an EH 
are entered into the database

Technical Support: The Americas

Available: Monday to Friday 8:00am - 6:30pm 
Eastern Standard Time 
Toll free within North America: 1-888-226-6876 
Direct Worldwide: +1 (613) 591-1943 
Email: technicalsupport@controlmicrosystems.com 

Technical Support: Europe, Africa, Middle East 
Available: Monday to Friday 8:30am - 5:30pm 
Central Europe Standard Time 

Direct Worldwide: +31 (71) 579 1650 
Email: euro-support@controlmicrosystems.com 

Technical Support: Asia Pacific

Available: Monday to Friday 8:30am - 5:30pm 
Australian Eastern Standard Time 
Direct Worldwide: +61 3 8773 0100 
Email: support@triodatacom.com
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Viewing Trends
The logged status poll data can be viewed in graph format, which allows 
viewing of status trends over selectable time spans.  This provides a 
very effective  method of analysing a units’ operating parameters over 
time.

Select “View Trend” under the Data Logging menu item or click the 
associated tool bar button.

Features available include:

•	 Scaling of graph(s).

•	 View individual poll results using the cursor.

•	 Automatically scroll through the group poll database, unit by 	
	 unit at a selectable time interval.

•	 No Acknowledge messages are displayed by a gap in the 	
	 graphed data and a “NoAck” in other on the Time Line.

The line above Status Polls is a “Processing Status Bar”.  It will display 
messages about errors, warnings and poll processing.

Vertical Scale Setting
•	 Manually set the vertical scales by typing in the new level(s), 

then either press “Enter” or click on the “Re Draw” button, or 
select a new unit.

•	 Click the “Default Ranges” button to set all the vertical 
scales back to the default levels.

•	 Click the “Set Ranges to Alarm Limits” button to set the 
vertical scale limits to the selected unit alarm limits.

From: & To: Fields
These fields determine the time span you wish to view.  For 
example, if you have collected several months of data, and only 
wish to view a 24 hour period, then adjust the From: and To: fields 
accordingly.

When the Trending window first appears, the From: and To: fields 
will contain the last 24 hours of data.

If “ALL” is selected it will display the start and end dates of the 
database.

Note:  The smaller the time span you select, the faster the 
database search and draw. This will also depend on the poll rate 
that was used during that time span.

Use the ALL button to set the From: and To: fields to the 
maximum and minimum dates found in the data in the database.

Poll Group Cycle
When toggled ON, this will step through each radio in the poll 
group and display the trend graph.  Set the step interval in the 
“Step Every (Sec)” field. Default = 2 seconds

Cursor:  Use the slider control, found at the bottom of the display 
to move the cursor.  The cursor box displays the parameter data 
of the status poll at the current cursor position.

Use the “Set From” button to set the From: field to the current 
cursor position.

Use the “Set To” button to set the To: field to the current cursor 
position.

Tools
The tools menu provides useful system tools for trouble shooting 
and maintaining a radio network using TView diagnostics.

Statistical Performance
Under the statistical performance menu, three separate tools are 
provide. 

Indicative Packet Error Testing
This tool provides a useful way to commission a radio modem 
communications link.

Indicative packet error testing works by sending a known packet 
of information to the selected unit and looking for a response. 
Each time a response is not heard the facility counts this as a 
lost packet. As soon as a response is heard from the remote unit, 
TView diagnostics sends another packet.

It is recommended that this test is done for at least 1000 
packets in order to get a meaningful result that is statistically 
valid. Ensure no other data (such as SCADA) is being transmitted 
on the radio network during the test.

To use the indicative packet error test facility, choose the unit 
you wish to test by using the “Selected Unit” drop down box .

Click on the start button and the test will commence.

Tx Packets
This indicates the number of packets TView+ diagnostics has transmitted 
to the remote unit.

Rx Packets
This indicates the number of packets TView+ diagnostics has received 
from the remote unit.

Lost Packets
This indicates the number of packets TView+ diagnostics has declared as lost. 

Error
This indicates the calculated Packet Error Rate in %. It is calculated from 
the ratio of Tx Packets to Rx Packets.

This indicates the normalised BER (Bit Error Rate) based on the number of 
bits per packet assuming only one bit was corrupted. It is only an estimate 
since two errored bits in one packet will only be counted as one errored bit.

Commissioning Record
For system commissioning and future records it is recommended to 
print a commissioning record. 

Before you print a record you are required to poll the radio for it’s diagnostics 
parameters and preferably perform an indicative packet error test.

This print out should be kept in a safe place and will be useful for 
monitoring the performance of a site over time.

4

Group Polling
In Group Polling mode, all radios that are part of the Poll Group 
(See Settings -> Poll Group select) are polled in succession. When 
diagnostics reaches the last radio in the poll group it returns to the 
top of the list.

Poll Repetition Time
Is the time in seconds (2 to 3600 secs) between each status 
poll of the group poll cycle.  Each unit in the poll group will be 
polled in turn, at this time interval.

Timed Polling
Allows the user to schedule a period when the group poll will 
commence.  This is a useful feature for systems that have times 
of minimal traffic loading such as the early hours of the morning.

Start Time
The time at which the Timed poll cycle will commence. The time 
format will be as per the regional settings of the operating system.

Number of Cycles
This is the number of times the controller will cycle through the poll 
group when the Timed Group poll commences. Each unit in the poll 
group will be polled this number of times.

HSC Group Polling (HSC Only)
This is the time in seconds (2-3600) between consecutive polls for 
each Hot Standby Controller status display. Diagnostics allows for up 
to 50 instances of the HSC status window. The poll repetition time 
is the time waited between each window. (i.e.: 3 HSC status windows 
with a time of 2 secs would take 6 seconds to complete an update on 
all three windows).

Base Digital I/O Polling (Base Only)
Is the time in seconds (2-3600) between consecutive polls for each 
base station digital I/O display. The timer behaves in the same way as 
the HSC group polling time.

Apply Changes
Applies and saves the changes made to configuration items in this menu.

For more detailed information consult the TView+ Diagnostics User Manual. 

Results are displayed in the “Status Polls” window along with 
the Unit Name and time of the poll. Group Polling is started by 
selecting the “Polling -> Group Polling” option.This menu allows the 
configuration of items related to polling.
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Step 3 - Check Controller settings.
The TView+ diagnostics controller has several settings which must be 
configured to be compatible with the radio which is connected to the 
computer running diagnostics.        

Controller Address: This is the unique address of the TView+ 
Diagnostics controller on the network. If you are running multiple 
copies of the TView+ Diagnostics controller you must ensure each 
installation has a unique Controller Address. This address is important 
when using  Automatic Diagnostics. Allowed range is 1-255.

Enable Trunk Stream Connection: This option is ticked only if a 
“trunked” port on the radio modem has been configured or Tview+ 
diagnostics is connected via a “System Port” on E, M or K series units.

Com Port: This drop down box shows the available COM ports. Select 
the port you have connected to the radio. 

Typical Diagnostics Port Settings: 

The following products are shipped from the factory with these default 
settings for diagnostics access :

D Series Radio : 

     Port B : 9600 bps - Enable Trunk Stream OFF 

E, M & K Series Radio :

     Systems Port : 19,200 bps - Enable Trunk Stream ON

Step 4 - Individual Polling
Connect the PC (running TView+ Diagnostics) to the appropriate 
port on the radio (consult the E,M  or K Series Quick Start Guide for 
details on radio connections).

To view the diagnostics parameters of a specific radio, open the 
Individual Polling screen by selecting “Polling->Individual Polling”.

Select the unit you wish to view by using the drop down “Select 
Unit” entry. 

After the unit has been selected, turn on polling by clicking on the 
“Polling” button. The Polling indicator should show “ON” as the 
status. The status bars should update as shown in the example 
above.

This completes the basic setup and configuration required for 
TView+ diagnostics. Refer to page 4 for details on how to use some 
of the advanced features.


